Помогите пожалуйста! Составить программу в паскаль, которая после ввода целого отрицательного числа N подсчитывает произведение всех отрицательных целых чисел от N до -N.
Ответы на вопрос
Ответил flash77779
0
Ответ:
program NegativeProduct;
var
N, i, product: integer;
begin
write('Enter a negative integer: ');
readln(N);
product := 1;
for i := N to -N do begin product := product * i; end;
writeln('The product of all negative integers from ', N, ' to ', -N, ' is ', product);
end.
Новые вопросы
var
N, product: integer;
begin
write('Введите целое отрицательное число N: ');
readln(N);
product := 1;
for N := N to -N do
begin
product := product * N;
end;
writeln('Произведение всех отрицательных целых чисел от N до -N: ', product);
end.