Помогите, пожалуйста!!!
Составить программу в Pascal,
Найти сумму произведений 1 и 2, 3 и 4, и тд элементов массива состоящего из 10 значений.
Заранее спасибо!
Ответы на вопрос
Ответил danulpopov
0
var
a:array[1..10] of integer;
i, ans:integer;
begin
Writeln('Введите массив из 10ти элементов: ');
for i:= 1 to 10 do
read(a[i]);
i:= 1; ans:= 0;
while i < 10 do
begin
ans:= ans + a[i] * a[i+1];
i:= i + 2;
end;
Writeln(ans);
end.
a:array[1..10] of integer;
i, ans:integer;
begin
Writeln('Введите массив из 10ти элементов: ');
for i:= 1 to 10 do
read(a[i]);
i:= 1; ans:= 0;
while i < 10 do
begin
ans:= ans + a[i] * a[i+1];
i:= i + 2;
end;
Writeln(ans);
end.
Новые вопросы
Математика,
2 года назад
Українська література,
2 года назад
Математика,
8 лет назад
Математика,
9 лет назад