Помогите, пожалуйста составить программу:)
В массиве а1, а2, ..., а50 определить
количество нулей
Ответы на вопрос
Ответил Аленусик
0
const n=50;
var a:array [1..n] of integer;
i,k:integer;
begin
for i:=1 to n do begin
a[i]:=random (21)-10;
if a[i]=0 then k:=k+1;
write (a[i]:4);
end;
writeln ('кол-во нулей =',k);
end.
var a:array [1..n] of integer;
i,k:integer;
begin
for i:=1 to n do begin
a[i]:=random (21)-10;
if a[i]=0 then k:=k+1;
write (a[i]:4);
end;
writeln ('кол-во нулей =',k);
end.
Ответил AlinkaMalinovskaya
0
почему (21)-10?
Ответил Аленусик
0
ну ты не указала интервал создаваемого массива. Поэтому я взяла из [-10;10]
Новые вопросы