Помогите пожалуйста составить программу правильно!!!!!
Вот условие:
Даны два действительных числа X и Y, не равные друг другу. Заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением. Программа должна иметь дружественный интерфейс.
На Паскале
Ответы на вопрос
Ответил KingRing7
3
Var x,y,t:real;
Begin
write('x = ');readln(x);
write('y = '); readln(y);
if x>y then
Begin
t:=y;
y:=(x+y)/2;
x:=x*t*2;
End
else
Begin
t:=x;
x:=(x+y)/2;
y:=x*t*2;
End;
writeln('X = ',x:0:2);
writeln('Y = ',y:0:2);
readln;
End.
Begin
write('x = ');readln(x);
write('y = '); readln(y);
if x>y then
Begin
t:=y;
y:=(x+y)/2;
x:=x*t*2;
End
else
Begin
t:=x;
x:=(x+y)/2;
y:=x*t*2;
End;
writeln('X = ',x:0:2);
writeln('Y = ',y:0:2);
readln;
End.
Новые вопросы
Окружающий мир,
2 года назад
Английский язык,
2 года назад
Литература,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад