Информатика, вопрос задал cюм , 7 лет назад



Помогите пожалуйста составить программу обработки массива из 5 ячеек,в которой суммируются все числа больше 10

Ответы на вопрос

Ответил fedrfedr
0

var

 A: array [1..5] of Integer;

 i, s: Integer;

begin

   Randomize;

   Write ('Массив: ');

   for i := 1 to 5 do begin

     A [i] := Random (20);

     Write (IntToStr (A [i]) + ' ');

   end;

   s := 0;

   for i := 1 to 5 do

     if  A [i] > 10 then

       s := s + A [i];

    Writeln;

   Writeln ('Cумма чисел больше 10 = ' + IntToStr (s));

end;

Новые вопросы