Информатика, вопрос задал катюша32454 , 9 лет назад

Помогите пожалуйста составить программу:
Найти наибольшее значение функции y=ax в квадрате+bx+c на отрезке [x1,x2]

Ответы на вопрос

Ответил archery
0
var
    y, a, b, c, x, x2, h, max: real;

begin
    write('Введите a,b,c');
    readln(a, b, c);
    write('Введите x1,x2 и шаг');
    readln(x, x2, h);
    
    max := a * x * x + b * x + c;
    repeat
        y := a * x * x + b * x + c;
        if max < y then max := y;
        x := x + h;
    until x > x2;
    
    writeln(max);
end.
Ответил NobunagaAndI3artle
0
Var
 i,max,x1,x2,a,b,c:integer;
begin
 read(x1,x2,a,b,c);
 max:=-2147483648;
 for i:=x1 to x2 do
 if a*sqr(i)+b*i+c>max then max:=a*sqr(i)+b*i+c;
 writeln(max);
end.
Новые вопросы