Информатика, вопрос задал anya26092 , 8 лет назад

ПОМОГИТЕ ПОЖАЛУЙСТА
Составить программу нахождения наименьшего общего кратного, используя следующую формулу A*B=НОД(А,В)*НОК(А,В)
НОК(А,В)=А*В/НОД(А,В)

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

function GCD_LCM(a,b:integer):(integer,integer);
begin
  var (c,d):=(a,b);
  while d>0 do (c,d):=(d,c mod d); // с - НОД
  Result:=(c,Trunc(a*b/c))
end;

begin
  var (a,b):=ReadInteger2('Введите два натуральных числа:');
  var (НОД,НОК):=GCD_LCM(a,b);
  Writeln('НОД = ',НОД, ', НОК = ',НОК)
end.

Пример
Введите два натуральных числа: 36 64
НОД = 4, НОК = 576
Новые вопросы