Информатика, вопрос задал askhatkorlanov25 , 6 лет назад

Помогите пожалуйста составить программу на Python через while и for:
Дан брусок длинной 20 метров. Напишите программу которая посчитает, какое минимальное целое количество отрезков длиной 1,5м и 2м получится из данного бруска.

Ответы на вопрос

Ответил lozromanik
1

Відповідь:

l=20

i=1.5

#for

for t in range(2):

   print(f"{l}-метровый брусок можно разбить на {l//i} брусков длиной {i} метров.")

   i+=0.5

#while

i=1.5

while i<2.5:

   print(f"{l}-метровый брусок можно разбить на {l//i} брусков длиной {i} метров.")

   i+=0.5

Новые вопросы