Помогите пожалуйста составить программу на Pascal:
1) Для нахождения суммы 2^2+4^2+...n^2
2) Для нахождения всех делителей числа n
Ответы на вопрос
Ответил Аноним
0
Var
n,i:integer;
S:real;
Begin
Write('n = ');ReadLn(n);
WriteLn('1)');
S:=0;
i:=2;
While i<=n do
Begin
S:=S+i*i;
i:=i+2;
End;
WriteLn('S = ',S);
WriteLn('2)');
Write(n);
i:=n div 2;
While i > 0 do
Begin
if n mod i = 0 then Write(' ',i);
i:=i-1
End;
End.
n,i:integer;
S:real;
Begin
Write('n = ');ReadLn(n);
WriteLn('1)');
S:=0;
i:=2;
While i<=n do
Begin
S:=S+i*i;
i:=i+2;
End;
WriteLn('S = ',S);
WriteLn('2)');
Write(n);
i:=n div 2;
While i > 0 do
Begin
if n mod i = 0 then Write(' ',i);
i:=i-1
End;
End.
Новые вопросы
Математика,
2 года назад
Английский язык,
2 года назад
Алгебра,
8 лет назад
Математика,
8 лет назад
Алгебра,
9 лет назад