Информатика, вопрос задал annazel7 , 8 лет назад

Помогите пожалуйста составить программу!!!!!!!!!!!!!!

Известный пират Флинт положил некоторую сумму S в банк по 3% годовых. Выведите на экран, через сколько лет сумма превысит 1,5S. Начальное значение S вводится с клавиатуры.

Ответы на вопрос

Ответил varan941
0
Смотрим: S-сумма, x-годовые, i-года
Решение в С++:

#include <iostream>
using namespace std;int main(void)
{
setlocale(LC_ALL, "Russian");
double S, x;
cout << "Введите сумму S : ";
cin >> S;
x = 3. * S / 100.;
cout<<"Годовой доход составляет: "<< x << endl;
int i;
i = 1.5*S / x;
if (i*x==1.5*S)
  {    i++;
   cout << "Через " << i << " год доход превысит 1.5*S и составит: "<< i * x<<endl;
   } else
   cout << "Через " << i << " лет доход превысит 1.5*S и составит: " << i * x << endl;
system("pause");
return 0;
}
Приложения:
Новые вопросы