Информатика, вопрос задал nikakorzh1999 , 7 лет назад

Помогите пожалуйста составить программу для рисования фигуры в Pascal ABC (она прикреплена). Дай бог здоровья тому кто поможет! Не разбираюсь в этом

Приложения:

Ответы на вопрос

Ответил vimmortal2
0

Программа:

Pascal:

Вводим количество кубиков, а потом программа рисует введённое количество кубиков в окне GraphABC.

uses graphABC;

var n: integer;

begin

 write('Количество кубиков: ');  readln(n);

 setpenwidth(2);

 for var i := 1 to n do

   if i mod 2 = 1 then

     rectangle(i * 100, 350, i * 100 + 100, 450)

   else

     rectangle(i * 100, 350, i * 100 + 100, 250);

end.


nikakorzh1999: Не получается, выдает ошибку в readln(n). Пишет, что имя n неизвестное
vimmortal2: у меня не выдаёт ошибку.
не может выдавать такую ошибку, так как мы имя во второй строке зарегистрировали
nikakorzh1999: Вот блин, а она рисует кубики, а такую фигуру как в задании нарисовать не может, что делать?
vimmortal2: эта фигура из кубиков сделана
vimmortal2: разницы нет)
nikakorzh1999: Ааа, хорошо, спасибо большое
Новые вопросы