Информатика, вопрос задал kolesina21 , 9 лет назад

Помогите пожалуйста составить программу.
Дано целое положительное число n.
Составить программу, которая, если число четное, выведет последнюю цифру этого числа.

Ответы на вопрос

Ответил lkairgeldin
0
uses crt;(если используешь абс паскаль) 
var n,b,k:integer;
begin
writeln ('n');
readln (n);
k:=n mod 2;
b:=n mod 10;
if k = 0 then writeln (b);
end.
Ответил lkairgeldin
0
может так?
Ответил kolesina21
0
всё равно, при вводе любого четного числа, оно и остается
Ответил kolesina21
0
если ввожу 96, в конце он должен выдать 6, а он выдает 96
Ответил lkairgeldin
0
все сам проверил
Ответил kolesina21
0
в 6 строке вот так только k:=n mod 2; и всё работает, спасибо огромное
Новые вопросы