Информатика, вопрос задал avgfresco , 7 лет назад

помогите пожалуйста





Словарь Паскаль:

функция Назначение

abs(x) Модуль х


sqr(x) Квадрат х


sqrt(x) Квадратный корень из х


round(x) Округление до ближайшего целого


int(x) Целая часть х


frac(x) Дробная часть х


div Получение целого частного при делении двух чисел Х на у


mod Получение целого остатка при делении двух чисел




«Исследование работы функций».


Составьте программу для решения задачи:

введите с клавиатуры число. Если оно отрицательное, то выведите на экран его модуль. Если дробное – выведите на экран его целую часть, дробную часть, а также округлите до ближайшего целого. Если число не подходит по условию – оставьте его без изменения.

Ответы на вопрос

Ответил leonidkorolev2007
0

Ответ:

var

a:real;

begin

readln(a);

if a<0

   then

       writeln(abs(a))

   else

       if frac(a)<>0

           then

               begin

                   writeln(int(a));

                   writeln(frac(a));

                   writeln(round(a));

               end

           else

               writeln(a);

end.

Объяснение:

Новые вопросы