Информатика, вопрос задал dobrya4ok4313 , 7 лет назад

Помогите пожалуйста с задачей в Python. Сделать с помощью генератора псевдослучайных чисел, оператор in, not in.

Задача: Напишите программу, которая вводит с клавиатуры непустой список целых чисел, и выводит число локальных максимумов (элемент является локальным максимумом, если он не имеет соседей, больших, чем он сам).


лекция: Числа в списке рандомные?
dobrya4ok4313: Какие захочешь главное чтобы целые числа были

Ответы на вопрос

Ответил лекция
0

A = list(map(int, input().split()))

kol = 0

for i in range(1, len(A) - 1):

   if A[i] > A[i-1] and A[i] > A[i+1]:

       kol += 1

print(kol)

числа списка задается в одну строку через пробел


dobrya4ok4313: А что за map и split?
dobrya4ok4313: Мы просто еще такое не проходили в школе
dobrya4ok4313: Спалят что не я сделал
dobrya4ok4313: Можно как-то без map и split эту задачу сделать?
dobrya4ok4313: Буду очень благодарен
лекция: Вместо "A = list(map(int, input().split()))" напиши A = [...], на месте многоточия перечисли нужные тебе числа через запятую
Новые вопросы