помогите пожалуйста с задачей) turbo pascal
составить программу к задаче :'числа a,b и c называются "пифагоровой тройкой",если выполняется условие a*a+b*b=c*c отыщите все пифагоровы тройки среди чисел от 1 до n
Ответы на вопрос
Ответил falcon22
2
Вот решение за O(n^3)
var
n,i,j,z:longint;
begin
read(n);
for i:=1 to n do
for j:=1 to n do
for z:=1 to n do
if (i*i+j*j=z*z) then writeln(i,' ',j,' ',z);
end.
var
n,i,j,z:longint;
begin
read(n);
for i:=1 to n do
for j:=1 to n do
for z:=1 to n do
if (i*i+j*j=z*z) then writeln(i,' ',j,' ',z);
end.
Новые вопросы
Русский язык,
1 год назад
Математика,
2 года назад
Обществознание,
2 года назад
Математика,
7 лет назад
Математика,
7 лет назад