Помогите пожалуйста с программой..(в Паскале)
Составить программу табулирования функции заданной рекурентной формулой.
f(0)=1; f(1)=2; f(n+2)=2*f(n+1)-n
Ответы на вопрос
Ответил kitchenrecords
0
function f(n:integer): integer;
begin
if n=0 then f := 1
else if n=1 then f := 2
else f := 2*f(n-1)-n+2;
end;
var n: integer;
begin
writeln('n':5, 'f(n)':10);
for n := 0 to 20 do
writeln(n:5, f(n):10);
end.
begin
if n=0 then f := 1
else if n=1 then f := 2
else f := 2*f(n-1)-n+2;
end;
var n: integer;
begin
writeln('n':5, 'f(n)':10);
for n := 0 to 20 do
writeln(n:5, f(n):10);
end.
Новые вопросы
Английский язык,
2 года назад
Математика,
2 года назад
Обществознание,
9 лет назад
Математика,
9 лет назад