Помогите пожалуйста с программой на С++. Даю 25 баллов.
Напишите функцию count для поиска количества элементов, равных заданному значению в массиве целых чисел.
Перегрузите эту функцию так, чтобы она могла работать с массивом вещественных чисел.
Для двух массивов - целочисленного и вещественного - выведите количества элементов, равных заданным.
Формат выходных данных
В первой строке выведите результат поиска в первом массиве, а во второй -- во втором массиве
Входные данные выходные данные:
5
68 52 14 601 96
61
6
30.89 58.12 3416 58.12 6.279 368.9
58.12
Выходные данные:
0
2
Ответы на вопрос
Ответ:
#include <iostream>
int count(int lenght, int a[], int entry ){
int cnt=0;
for( int i=0; i < lenght; i++){
if( a[i] == entry )
cnt++;
}
return cnt;
}
int count(int lenght, float a[], float entry ){
int cnt=0;
for( int i=0; i < lenght; i++){
if( a[i] == entry )
cnt++;
}
return cnt;
}
int main(void){
int lenght;
std::cin >> lenght;
int arr[lenght];
for( int i=0; i<lenght; i++ ){
(std::cin>>arr[i]).get();
}
int entry;
std::cin >> entry;
int lenght2;
std::cin>>lenght2;
float arr2[lenght2];
for( int i=0; i<lenght2; i++ ){
(std::cin>>arr2[i]).get();
}
float entry2;
std::cin >> entry2;
std::cout << count( lenght, arr, entry ) << std::endl;
std::cout << count( lenght2, arr2, entry2 ) << std::endl;
return 0;
}
Объяснение: