Помогите пожалуйста с паскалем.
Составить блок схему. Составить программу на языке паскаль.
Дан массив в котором все элементы различны. Удалить из него минимальный элемент.
Ответы на вопрос
Ответил Аноним
0
const
m = 10;
var
a: array[1..m] of integer;
i,j, min: integer;
begin
write ('Исходный массив: ');
for i := 1 to m do
begin
a[i] := random(100);
if (i=1) or (a[i]<min) then min:=a[i];
write (a[i],'; ');
end;
writeln;
for i:=1 to m do
begin
if a[i]=min then
begin
for j:=i to m-1 do
a[j]:=a[j+1];
break;
end;
end;
a[m]:=0;
write('Измененный массив: ');
for i := 1 to m-1 do
write (a[i],'; ');
end.
m = 10;
var
a: array[1..m] of integer;
i,j, min: integer;
begin
write ('Исходный массив: ');
for i := 1 to m do
begin
a[i] := random(100);
if (i=1) or (a[i]<min) then min:=a[i];
write (a[i],'; ');
end;
writeln;
for i:=1 to m do
begin
if a[i]=min then
begin
for j:=i to m-1 do
a[j]:=a[j+1];
break;
end;
end;
a[m]:=0;
write('Измененный массив: ');
for i := 1 to m-1 do
write (a[i],'; ');
end.
Приложения:


Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Математика,
9 лет назад
Математика,
10 лет назад