Информатика, вопрос задал Jeyberg , 1 год назад

Помогите, пожалуйста, с написанием программы. (Python)

Ограничение времени 1 секунда

Ограничение памяти 64Mb

Ввод стандартный ввод

Вывод стандартный вывод


Все очень просто. Если у вас есть знакомая ведьма, в особенности, довольная ведьма, то вам крупно повезло. Помните, если вы повстречали невысокую, крепко сбитую ведьму, следует предложить ей обед, ну, или, на худой конец, пару лепешек. Это принесет вам счастье.


Напишите программу, которая определит, когда следует ожидать наступления счастья после встречи с ведьмой в зависимости от величины того, что вы ей предложили


Формат ввода


Исходная дата в формате YYYY/MM/DD.

Величина подношения – целое число.

Количество дней, которые нужно определить.


Формат вывода.


Выводится требуемое количество дней в виде, показанном в примерах, каждое с новой строки.

Дни определяются так: это не может быть суббота или воскресенье, в эти дни и так неплохо. Чем больше подношение, тем быстрее должно наступить счастье, поэтому количество дней ожидания равно 100 // подношение. Подходящий день наступает не раньше, чем истечет время ожидания.


Пример 1

Ввод:

2021/02/23

6

3

Вывод:

Thu 11 Mar

Fri 12 Mar

Mon 15 Mar


Пример 2

Ввод:

2021/05/17

10

5

Вывод:

Thu 27 May

Fri 28 May

Mon 31 May

Tue 01 Jun

Wed 02 Jun

Ответы на вопрос

Ответил archie242
0

Відповідь:

import datetime

date_str, offering, num_days = input().split()

offering = int(offering)

num_days = int(num_days)

date = datetime.datetime.strptime(date_str, '%Y/%m/%d')

days_wait = 100 // offering

current_day = 1

while num_days > 0:

   if date.weekday() not in [5, 6]:

       if current_day >= days_wait:

           print(date.strftime('%a %d %b'))

           num_days -= 1

       current_day += 1

   date += datetime.timedelta(days=1)

Новые вопросы