Информатика, вопрос задал sabrinalev , 1 год назад

Помогите пожалуйста, с информатикой. Написать программу:
Массив из 30 элементов заполнить случайным образом целыми числами от 0 до 10, найти сумму всех его элементов и вывести её на экран.
Я начала писать ( на фото), но не уверена и не знаю, что дальше

Приложения:

Ответы на вопрос

Ответил Hung1337
2

Ты почти правильно все написала :)

var a : array[1..30] of integer;  // определяем массив, который будет состоять из 30 чисел типа integer (целых)

   i, sum : integer;  // Переменная i для итерации в цикле, sum - для суммы

begin

 sum := 0; //В начале сумма равна нулю

 randomize(); //инизициализиуем датчик псевдослучайных чисел

 for i := 1 to 30 do begin  // цикл, который будет повторяться 30 раз

   a[i] := random(0,10);  // Говорим, что элемент с индексом i в массиве равен рандомному числу от 0 до 10

   sum := sum + a[i];  // Прибавляем к переменной sum элемент массива с индексом i

 end;

 write('Сумма: ' + sum) //Выводим

end.


sabrinalev: Я учту, спасибо большое за подробное пояснение! :)
Новые вопросы