помогите пожалуйста с информатикой
надо записать программу на паскале
кто понимает,помогите пожалуйста
буду очень благодарна
Рассматривается множество целых чисел, принадлежащих числовому отрезку [1529; 9482], которые удовлетворяют следующим условиям:
− запись в двоичной системе закачивается на 01;
− запись в пятеричной системе заканчивается на 3.
Найдите минимальное из таких чисел и их сумму. Гарантируется, что искомая сумма не превосходит 107.
123325736:
(a mod 100 = 01) and (b mod 10 =3) then begin if i
Ответы на вопрос
Ответил restIess
2
var
i,a,j,k,b,s,counter : integer;
begin
s := 0;
counter := 1;
for i := 1529 to 9482 do
begin
j:= i;
k := i;
repeat a:= a*10+(j mod 2);
j:=j div 2;
until j=0;
repeat b:=k*10 + (k mod 5);
k:=k div 5;
until k=0;
if (a mod 100 = 01) and (b mod 10 = 3) then
begin
s := s + i;
if counter = 1 then
begin
counter := counter + 1;
writeln('Минимальное такое число:', i);
end;
end;
end;
writeln('Сумма чисел:',s);
end.
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
Математика,
8 лет назад
Алгебра,
8 лет назад