Информатика, вопрос задал saigulr , 1 год назад

Помогите пожалуйста решить задания в питоне (Python) всего 1 задания даю 15 баллов!
Надо написать программу, которая принимает текст и выводит два слова: наиболее часто встречающееся и самое длинное. Без import.



Очень благодарю если ответите.


vtoper: текст, или определенное кол-во слов?

Ответы на вопрос

Ответил amanbekmedetov
1

Ответ:

n = input()

n=n.replace("."," ")

n=n.replace(","," ")

n=n.replace("!"," ")

n=n.replace("?"," ")

n=n.replace("-"," ")

n=n.replace("("," ")

n=n.replace(")"," ")

n = n.split()

maxlength = ""

maxcount  = ""

for a in range(len(n)):

   if len(n[a])>len(maxlength):

       maxlength = n[a]

   if n.count(n[a])>len(maxcount):

       maxcount = n[a]

 

print("maxcount: "+maxcount)

print("maxlength: "+maxlength)

Объяснение:

str.replace(old,new) = заменяет old_word на new_word (чтобы очищать от . , ! ? ( ) -символов(ещё есть другие но эти основные(можешь просто копировать вставить заменить на другие))

str.split() = разделяет строку по пробелам

array.count()=считает количество строк в данном массиве

len(array) = дает длину массива

Новые вопросы