Информатика, вопрос задал saigulr , 1 год назад

Помогите пожалуйста решить задания в питоне (Python) даю 11 баллов!
Надо написать программу, которая принимает текст и выводит два слова слова: наиболее часто встречающееся слова и самое длинное слово.

Буду очень благодарен.

Ответы на вопрос

Ответил amanbekmedetov
0

Ответ:

n = input()

n=n.replace("."," ")

n=n.replace(","," ")

n=n.replace("!"," ")

n=n.replace("?"," ")

n=n.replace("-"," ")

n=n.replace("("," ")

n=n.replace(")"," ")

n = n.split()

maxlength = ""

maxcount  = ""

for a in range(len(n)):

   if len(n[a])>len(maxlength):

       maxlength = n[a]

   if n.count(n[a])>len(maxcount):

       maxcount = n[a]

 

print("maxcount: "+maxcount)

print("maxlength: "+maxlength)

Объяснение:

есть нюанс:а что если 2 или больше слова которые может быть одинаково длиной какую должен выводит?

Новые вопросы