Помогите, пожалуйста решить задачу в Паскале!
Однажды первокласснику Вовочке задали задание сложить из спичек прямоугольник, и вычислить его площадь. С заданием Вовочка справился, однако заметил, что из одного и того же количества спичек можно сложить разные прямоугольники, а иногда, чтоб сложить прямоугольник, не удается использовать все спички. Например из 14 спичек можно сложить прямоугольники со сторонами 1 и 6, 2 и 5, 3 и 4. Естественно, Вовочке хочется сложить прямоугольник максимальной площади, но это для него слишком сложная задача. Напишите программу, которая по данному количеству спичек определит, какой максимальной площади можно составить прямоугольник из этих спичек (спички ломать не разрешается)
Ответы на вопрос
Ответил xerex21
0
var a,b,n,max: integer;
begin
max:=0;
write('Количество спичек: ');
readln(n);
for a:=1 to n div 2 do
begin
for b:=a to n div 2 do
begin
if (a*b>max)and ((2*a)+(2*b)<=n) then
max:=a*b;
end;
end;
write('Максимальная площадь: ',max);
end.
begin
max:=0;
write('Количество спичек: ');
readln(n);
for a:=1 to n div 2 do
begin
for b:=a to n div 2 do
begin
if (a*b>max)and ((2*a)+(2*b)<=n) then
max:=a*b;
end;
end;
write('Максимальная площадь: ',max);
end.
Ответил xerex21
0
.?
Ответил 987654342567
0
Ну в смысле не всегда выводит правильный ответ
Ответил 987654342567
0
:)
Ответил 987654342567
0
:(
Ответил xerex21
0
можно пример?
Новые вопросы
Английский язык,
2 года назад
Литература,
2 года назад
Алгебра,
8 лет назад
Алгебра,
9 лет назад
Математика,
9 лет назад