Информатика, вопрос задал max98frommks , 8 лет назад

Помогите пожалуйста решить задачу в Pascal ABC Написать программу, которая вычисляет факториал числа, введенного с клавиатуры. (факториал числа n называется произведение целых чисел от 1 до n. Например, факториал числа 1 равен 1, а числа 8 – 40320.)
Вычисление факториала.
Введите число, факториал которого надо вычислить -> 7
Факториал 7 равен 5040.

Ответы на вопрос

Ответил Аноним
0
Var
N:integer;
F:BigInteger:=1;
Begin
Write('N = ');Read(N);
For N:= 1 to N do
    F:=F*N;
Write(N,'! = ',F)
End.
Новые вопросы