Помогите пожалуйста решить задачи в турбо Паскале!
1) Определить количество двухзначных чисел, сумма цифр которых равна числу N.
2) Составить таблицу для двух столбцов выражения y=x²+3. Ввод чисел через клавиатуру.
3) Составить программу вычисления суммы кубов чисел от 1 до 5.
4) Вычислить сумму части ряда, 1/3, 1/6, 1/9, 1/12....
5) Среди двухзначных чисел, найти те, сумма цифр которых делятся на 3.
6) Найти самую большую цифру:
а) в двухзначном числе
б) трехзначном числе.
Ответы на вопрос
Ответил nikolac
0
1)uses crt;
var i,j,n,ans:integer;
begin
read(n);
for i:=1 to 9 do
for j:=0 to 9 do
if i+j=n then
ans:=ans+1;
writeln(ans);
end.
2)
uses crt;
var i,n:integer;
x:array[1..100] of integer;
begin
writeln('Введите количество x и значения: ');
read(n);
for i:=1 to n do
read(x[i]);
writeln('x y');
for i:=1 to n do
writeln(x[i],' ',x[i]*x[i]+3);
end.
3.
uses crt;
var i:integer;
begin
for i:=1 to 5 do
write(i*i*i,' ');
end.
4.
uses crt;
var i,n,sum:real;
begin
writeln('Введите N:');
read(n);
i:=3;
while i<=n do
begin
sum:=sum+1/i;
i:=i+3;
end;
writeln(sum);
end.
5.
uses crt;
var j,i,n,sum:integer;
a:array[1..100] of integer;
begin
writeln('Введите количество чисел и сами числа:');
read(n);
for i:=1 to n do
begin
sum:=0;
read(a[i]);
for j:=1 to length(inttostr(a[i])) do
sum:=sum+strtoint(inttostr(a[i])[j]);
if sum mod 3 = 0 then
write(a[i],' ');
end;
end.
6.a)uses crt;
var n:string;
begin
read(n);
writeln(max(strtoint(n[1]),strtoint(n[2])));
end.
б)
uses crt;
var n:string;
begin
read(n);
writeln(max(max(strtoint(n[1]),strtoint(n[2])),strtoint(n[3])));
end.
Ответил pro72ru
0
а ты по порядку напиши еще раз
Ответил pro72ru
0
тож самое, не работает вот именно где "if ord(n[i])>max then"
Новые вопросы
Немецкий язык,
2 года назад
История,
2 года назад
География,
10 лет назад
Математика,
10 лет назад
Алгебра,
10 лет назад