Информатика, вопрос задал мы13 , 9 лет назад

Помогите пожалуйста решить!)
Составить программу, которая печатает true, если точка с координатами (х, у) принадлежит заштрихованной области, и false в противном случае:

Приложения:

Ответы на вопрос

Ответил Аноним
0
По рисунку 1:

var
  x, y: real;

begin
  Write('Введите через пробел координаты точки x,y: ');
  Readln(x, y);
  Writeln((y <= abs(x - 4)) and (y <= 4))
end.

Тестовое решение:
Введите через пробел координаты точки x,y: 3.15 -0.72
True

Введите через пробел координаты точки x,y: 3 3
False

По рисунку 2:

var
  x, y: real;
  p,q:boolean; {только для сокращения операторов}

begin
  Write('Введите через пробел координаты точки x,y: ');
  Readln(x, y);
  p:=(sqr(x)+sqr(y)<=25);
  q:=(sqr(x)+sqr(y)>=9);
  Writeln((x>=0.5) and p and q)
end.

Тестовое решение:
Введите через пробел координаты точки x,y: 4 2.5
True

Введите через пробел координаты точки x,y: 3.7 -4.3
False

Введите через пробел координаты точки x,y: 2 -3
True







Новые вопросы