Помогите пожалуйста решить С++
Написать программу с функцией для распечатки в обратном
(инверсном) порядке текстовой строки, реализованной в виде символьного массива. Рассмотреть возможность использования рекурсии.
Ответы на вопрос
Ответил ooooor642
0
Ответ:
/*cpp-файл с комментариями к коду в закрепе*/
#include <iostream>
using namespace std;
void reverse(char *str);
void main()
{
setlocale(LC_ALL, "RU");
char str[80];
cin >> str;
reverse(str);
}
void reverse(char* str) {
if (*str)
reverse(str + 1);
else
return;
cout << *str;
}
Приложения:
Новые вопросы
Математика,
2 года назад
Геометрия,
2 года назад
Английский язык,
7 лет назад
Алгебра,
7 лет назад
Физика,
8 лет назад