Информатика, вопрос задал mobileTanks , 2 года назад

Помогите пожалуйста решить на паскале.
С клавиатуры вводятся координаты точки на плоскости (x, y – действительные числа. Написать программу, определяющую принадлежность точки заштрихованной области, включая ее границы.

Приложения:

Ответы на вопрос

Ответил fedrfedr
1

Ответ:

program Test;

var

 x, y: Double;

begin

 WriteLn ('Введите координаты x и y: ');

 ReadLn (x, y);

 if (x >= 0) and (x <= Pi) and (y >= 0) and (y <= 0.5) and (y <= Sin (x)) then

   WriteLn ('Принадлежит')

 else

   WriteLn ('Не принадлежит');

 ReadLn;

end.

Объяснение:

Первые 4 условия проверяют прямоугольник от (0, 0) до (п, 0,5)

последнее условие проверяет левый и правый край этого прямоугольника на принадлежность к графику Sin (x)

Новые вопросы