Информатика, вопрос задал pplotnikov643 , 7 лет назад

Помогите Пожалуйста, ( Python ). 20+Бал

Напишите программу, которая вводит натуральные числа a , b и N , и выводит на экран N псевдослучайных целых чисел на отрезке [ a , b ] .

Входные данные
Входная строка содержит три числа, разделённые пробелами: границы отрезка a и b и требуемое количество чисел N . Гарантируется, что a ≤ b .

Выходные данные
Программа должна вывести N случайных целых чисел в одной строке, разделив их пробелами.

Примеры|:

входные данные
10 20 5
выходные данные
10 10 19 12 13

Ответы на вопрос

Ответил FANTSCR1N
1

import random

string = input('Введите данные: ').strip()

data = string.split(' ')

a = int(data[0])

b = int(data[1])

N = int(data[2])

print(f'{" ".join(str(random.randint(a, b)) for _ in range(N))}')


pplotnikov643: SyntaxError: invalid syntax
Ответил Аноним
1

Ответ:

from random import randint

a, b, n = map(int, input().split())

for i in range(n):

   print(randint(a, b), end=' ')

Объяснение:


pplotnikov643: Ничего не выводет
Аноним: 10 20 5
18 20 19 11 16
Process finished with exit code 0
Аноним: все работает и выводит
FANTSCR1N: Чисто интересно где вы проверяете?
Аноним: и у первого ответа тоже все работает
FANTSCR1N: Дак вот, странно. Может какой-то онлайн компилятор
Аноним: PyCharm
FANTSCR1N: Да, я про чела который вопрос задал
Аноним: и в IDLE тоже все работает
Аноним: )))))
Новые вопросы