Помогите пожалуйста,последняя надежда(
Составить программу, которая формирует матрицу из n*n случайных чисел. Определить произведение чисел, лежащих на побочной диагонали матрицы. Значение n меняется в пределах от 5 до 10 тысяч.
Вариант 7
Pascal
nikniklas:
размер n запрашивается у пользователя?
Ответы на вопрос
Ответил nikniklas
1
Ответ:
const n=5;
var
A:array[1..n,1..n] of integer;
i,j:integer;
proizv:real;
begin
randomize;
for i:=1 to n do
for j:=1 to n do
begin
{число для рандома 10000-5+1 и потом увеличиваем на 5, т.е. от 5}
A[i,j]:=random(9996)+5;
end;
write('Исходная матрица A: ');
for i:=1 to n do
begin
writeln;
for j:=1 to n do
write(A[i,j]:2,' ');
end;
proizv:=1;
for i:=1 to n do
proizv:=proizv*A[i,n+1-i];
writeln;
writeln('Произведение = ',proizv);
end.
Объяснение:
n - ставится в константе
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Русский язык,
7 лет назад
Биология,
7 лет назад
История,
8 лет назад