помогите пожалуйста, поблагодарю:
написать программу которая суммирует все четные числа введенные с клавиатуры ( ввести 6 чисел)
Ответы на вопрос
Ответил blowberryninja
0
program p1;
var a,n,sum:integer;
begin
for a:=1 to 6 do begin
readln(n);
if n mod 2=0 then sum:=sum+n;
end;
writeln('sum=',sum);
end.
var a,n,sum:integer;
begin
for a:=1 to 6 do begin
readln(n);
if n mod 2=0 then sum:=sum+n;
end;
writeln('sum=',sum);
end.
Ответил blowberryninja
0
Исправил.
Ответил яна4ка
0
спасибо
Ответил atas98
0
Это метод на C#
int Sum()
{
int[] nums = new int[5]; //Создаю целочисленный массив из 6 элементов для чисел
int ans; //Целочисленная переменная для ответа
for(int x = 0; x < 6; x++)//Цикл для ввода значений
{
Console.Write("Введите ", x ," число: ");
nums[x]=(int)Console.ReadLine(); //Ввод числа и запись в массив
}
ans=nums[0]+nums[1]+nums[2]+nums[3]+nums[4]+nums[5] /* Суммирование всех элементов массива и запись результата в переменную */
Console.WriteLine("Сумма чисел: ",ans); // Вывод ответа
return ans; //Возврат ответа из метода
}
int Sum()
{
int[] nums = new int[5]; //Создаю целочисленный массив из 6 элементов для чисел
int ans; //Целочисленная переменная для ответа
for(int x = 0; x < 6; x++)//Цикл для ввода значений
{
Console.Write("Введите ", x ," число: ");
nums[x]=(int)Console.ReadLine(); //Ввод числа и запись в массив
}
ans=nums[0]+nums[1]+nums[2]+nums[3]+nums[4]+nums[5] /* Суммирование всех элементов массива и запись результата в переменную */
Console.WriteLine("Сумма чисел: ",ans); // Вывод ответа
return ans; //Возврат ответа из метода
}
Новые вопросы
Математика,
2 года назад
Русский язык,
2 года назад
История,
9 лет назад
Алгебра,
9 лет назад
Физика,
10 лет назад
Математика,
10 лет назад