Информатика, вопрос задал ocvsrs , 1 год назад

Помогите пожалуйста по информатике Python
Chapter 1.1
1. Напишите код для ввода двух чисел. Вычислите их разницу.
2. Вычислите остаток деления 36 на 5
3. Напишите проверку на то, является ли строка палиндромом.
Палиндром — это слово или фраза, которые одинаково читаются
слева направо и справа налево.
4. Дана строка “I love Java”. Выведите первые два слова иI love Java”.
Выведите первые два слова и добавьте к ним Python.
5. Напишите код для ввода текста. Введите свое имя и выведите
его в терминал 10 раз.
6. Напишите код для ввода текста. Выведите все буквы в обратном
порядке.
7. Напишите код для ввода числа. Выведите его 10 цифру по порядку
(Учтите, что число может быть коротким, в таком случае начинайте
отсчет с первой цифры).
8. Напишите программу для получения первых 2 и последних 2
символов в строке. Если строка содержит 2 символа, выведите их 2
раза. Если в строке 2 символа, выведите саму строку. Если строка
содержит меньше 2 символов, то выведите сообщение «Error».Error».
Строка: 'You know nothing, John Snow'
Результат: 'Yoow'
Строка : 'hi'
Результат : 'hi'
Строка : ''
Результат : Error
9. Напишите код для ввода числа. Выведите его предыдущее и
следующее числа. (Например пользователь ввел 5. Вывод должен
быть: 4, 6)
10. Пользователь вводит два числа. Сравните эти числа и выведите
результат.

Пример:
First number: 10
Second number: 5
Результат: 10 > 5
11. Пользователь вводит число. Проверьте отрицательное оно или
положительное и выведите результаты (0 не является ни
положительным, ни отрицательным)

Ответы на вопрос

Ответил dimonchop
3

Відповідь:

1.

num1 = int(input("Enter the first number: "))

num2 = int(input("Enter the second number: "))

diff = num1 - num2

print("The difference between", num1, "and", num2, "is", diff)

---------------------------------------------------------------------------------------------

2.

num = 36

divisor = 5

remainder = num % divisor

print("The remainder of dividing", num, "by", divisor, "is", remainder)

---------------------------------------------------------------------------------------------

3.

def is_palindrome(word):

   return word == word[::-1]

word = input("Enter a word or phrase: ")

if is_palindrome(word):

   print(word, "is a palindrome.")

else:

   print(word, "is not a palindrome.")

---------------------------------------------------------------------------------------------

4.

phrase = "I love Java"

first_two_words = phrase[:6]

print("The first two words:", first_two_words)

new_phrase = first_two_words + " Python"

print("New phrase:", new_phrase)

---------------------------------------------------------------------------------------------

5.

for i in range(10):

   name = input("Enter your name: ")

   print("Exit ego")

---------------------------------------------------------------------------------------------

6.

word = input("Enter a word: ")

reversed_word = word[::-1]

print("The word in reverse order:", reversed_word)

---------------------------------------------------------------------------------------------

7.

num = input("Enter a number: ")

for i in range(10):

   try:

       print(num[i % len(num)])

   except IndexError:

       print("Error: The number has less than 10 digits.")

       break

---------------------------------------------------------------------------------------------

8.

string = input("Enter a string: ")

if len(string) >= 2:

   first_two = string[:2]

   last_two = string[-2:]

   result = first_two + last_two

   print("Result:", result)

elif len(string) == 1:

   result = string * 2

   print("Result:", result)

else:

   print("Error")

---------------------------------------------------------------------------------------------

9.

num = int(input("Enter a number: "))

prev_num = num - 1

next_num = num + 1

print("Previous number:", prev_num)

print("Next number:", next_num)

---------------------------------------------------------------------------------------------

10.

num1 = int(input("Enter the first number: "))

num2 = int(input("Enter the second number: "))

if num1 > num2:

   print(num1, "is greater than", num2)

elif num1 < num2:

   print(num1, "is less than", num2)

else:

   print(num1, "is equal to", num2)

---------------------------------------------------------------------------------------------

11.

num = int(input("Enter a number: "))

if num > 0:

   print(num, "is positive.")

elif num < 0:

   print(num, "is negative.")

else:

   print(num, "is neither positive nor negative.")


dimonchop: 11 будет совсем скоро!
ocvsrs: благодарю Вас ,спаситель наш
dimonchop: Обновил, добавил 11 пункт!
ocvsrs: огромное спасибо
ocvsrs: в 10 выдает ошибку в 7 строке
ocvsrs: в 11 в 5 строке ошибку выдает
ocvsrs: в 7 в 5 строке ошибку выдает
ocvsrs: в 5 3 строка ошибку выдает
ocvsrs: в 4 7 строка ошибку выдает
ocvsrs: куда можно ошибки отправить
Новые вопросы