Информатика, вопрос задал Andry53 , 1 год назад

Помогите пожалуйста по C++!


Изменение исходного массива


Дан двумерный массив из четного числа строк размером n×m. Требуется составить программу, которая меняет местами первую строку со второй, третью — с четвертой и т. д.


Первая строка содержит два натуральных числа n, m (n,m≤100).


Следующие n строк содержат по m чисел, не превосходящих 109 по модулю — элементы массива.


Требуется вывести n строк по m чисел в каждой — измененный массив.


входные данные

4 3

1 2 3

4 5 6

7 8 9

9 8 7


выходные данные

4 5 6

1 2 3

9 8 7

7 8 9

Ответы на вопрос

Ответил witchmay
2

#include <iostream>

int main(){

  int n, m;

  std :: cin >> n >> m;

  int array[109][109];

  for (int i = 0; i<n; ++i){

      for (int j = 0; j<m; ++j)

      {

            if (i==0 || i%2==0) std :: cin >> array[i+1][j];

            else std :: cin >> array[i-1][j];

      }

  }

   for (int i=0; i<n; ++i){

       for (int j= 0; j<m; ++j)

       {

            std :: cout << array[i][j]<< ' ';

       }

       std :: cout << std :: endl;

   }

}

Новые вопросы