Информатика, вопрос задал vavandriy , 2 года назад

Помогите пожалуйста. Питон. 2 задачи
5. Напишите программу, которая заполняет массив случайными трёхзначными числами и находит в нём элемент с наибольшей суммой цифр, и его индекс.

6. Введите с клавиатуры значения элементов массива и найдите два элемента, которые больше всех остальных.

Ответы на вопрос

Ответил Аноним
0

Ответ:

№5

import random as r

mass = [r.randint(100, 999) for s in range(10)]

print(*mass)

mx = 0

for i in range(1, len(mass)):

   if sum(map(int, str(mass[i]))) > sum(map(int, str(mass[mx]))):

       mx = i

print(mass[mx], mx)

№6

mass = [int(s) for s in input().split()]

for i in range(len(mass) - 1):

   for j in range(i + 1, len(mass)):

       if mass[j] < mass[i]:

           mass[j], mass[i] = mass[i], mass[j]

print(mass[j], mass[i])

Объяснение:

Новые вопросы