Информатика, вопрос задал annafadeeva82 , 9 лет назад

помогите пожалуйста!! паскаль
Входными данными являются число k, N и N целых чисел.
В массиве определить индекс k-го наибольшего элемента массива.
Считать, что все элементы разные.
Ограничения:
Считать, что все элементы разные.
N принимает значения от 1 до 20.
k принимает значения от 1 до N.
Формат входных данных:
k, N и N целых чисел
Формат выходных данных:
индекс второго наибольшего элемента массива

Ответы на вопрос

Ответил Аноним
0
var
  i,j,n,k: integer;
  a,b:array[1..20]of integer;
begin
writeln('Введите N');
readln(n);
for i:=1 to n do
  begin
  readln(a[i]);
  b[i]:=a[i];
  end;
for i:=1 to n do
  for j:=1 to n do
    if b[i]>b[j] then
      begin
      k:=b[i];
      b[i]:=b[j];
      b[j]:=k
      end;
for i:=1 to n do
  if a[i]=b[2] then k:=i;
writeln('k=',k);
end.
Новые вопросы