Помогите пожалуйста!! Pascal.
На вход программе подается `3` числа: номер дня в месяце, номер месяца и год. Вывести номер дня недели (`1`– понедельник, `7`–воскресенье) соответствующего этой дате.
Ответы на вопрос
Ответил DonSERG
1
Ответ:
Объяснение:
var
d, m, y, w, a: longint;
begin
readln(d, m, y);
a := (14 - m) div 12;
y := y - a;
m := m + 12 * a - 2;
w := (d + 31 * m div 12 + y + y div 4 - y div 100 + y div 400 + 6) mod 7 + 1;
writeln(w);
readln
end.
DazaiOsamu14:
Спасибо
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Физика,
7 лет назад
Математика,
8 лет назад