Информатика, вопрос задал янкочка , 10 лет назад

ПОМОГИТЕ ПОЖАЛУЙСТА!! PASCAL !
1. Составьте программу, вычисляющую, сколько букв надо исправить в слове Х, чтобы получилось слово Y (слова X  и Y одинаковой длины).
2. Составьте программу, определения номера первой буквы "а" в слове Х.
3. Составьте программу, позволяющую выяснить, первая или последняя буква слова встречается в слове Х чаще.

Ответы на вопрос

Ответил yuliagal
0
Задача 1.
var
  i,c: integer;
  x,y: string;

begin
  readln(x);
  readln(y);
  for i:=1 to length(x) do
    if x[i]<>y[i] then inc(c);
  writeln('Букв надо исправить = ',c)
end.

Задача 2.

var
  i: integer;
  x: string;

begin
  readln(x);  i:= 1;
  while x[i]<>'a' do inc(i);  // Здесь, в зависимости с какой буквой сравнивать, либо с русской, либо с англ.
  writeln(i)
end.
Новые вопросы