Информатика, вопрос задал альстофер , 8 лет назад

Помогите, пожалуйста! Очень вас прошу! Через паскаль! num, res
Написать программу, которая в последовательности натуральных чисел определяет наибольшее, квадрат, которого не превосходит число 225.
Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода и не входит в последовательность).
Программа должна вывести одно число: наибольшее число в последовательности, квадрат которого не превышает число 225.
Не использовать: const, count и другие

Ответы на вопрос

Ответил Crazzyone
0

program zadanie;
var
max,num,a :byte;
label metka;
begin
max:=0;
writeln('vvodite chisla');
metka:
readln(a);
if a=0 then
writeln ('max=',max)
else
    if a*a>225 then
       begin
            writeln('Slishkom bolshoe chislo');
            goto metka;
       end
    else
        begin
             if max<a then max:=a;
             goto metka;
        end;
readln;
end.


Ответил альстофер
0
и label metka?
Ответил Аноним
0
))))) goto, значит, проходили? или проходили и мимо прошли?
Ответил альстофер
0
да, нет я имел ввиду что значит label
Ответил Crazzyone
0
label [имя метки] это метка, т.е. место в программе, куда можно вернуться в любой момент перейдя по ссылке goto [имя метки] не просто так спрашивал проходили ли метки
Ответил Crazzyone
0
странно, что не смутило metka:
Новые вопросы