ПОМОГИТЕ,ПОЖАЛУЙСТА,очень срочно
нужно написать программу в Pascal(ABC)
Приложения:

Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
var s:=ReadlnString('Введите строку:');
var c:=ReadlnChar('Введите искомую букву:');
var w:=s.ToWords;
var n:=w.Count;
var iw:=0;
var wd:='';
for var i:=0 to n-1 do begin
var nc:=w[i].ToCharArray.Where(x->x=c).Count;
if nc>iw then begin wd:=w[i]; iw:=nc end
end;
if iw>0 then Writeln('Нашли слово: ',wd)
else Writeln('Нет слов с "',c,'"')
end.
Тестовое решение:
Введите строку: карл у клары украл кораллы клара у карла украла кларнет
Введите искомую букву: а
Нашли слово: клара
begin
var s:=ReadlnString('Введите строку:');
var c:=ReadlnChar('Введите искомую букву:');
var w:=s.ToWords;
var n:=w.Count;
var iw:=0;
var wd:='';
for var i:=0 to n-1 do begin
var nc:=w[i].ToCharArray.Where(x->x=c).Count;
if nc>iw then begin wd:=w[i]; iw:=nc end
end;
if iw>0 then Writeln('Нашли слово: ',wd)
else Writeln('Нет слов с "',c,'"')
end.
Тестовое решение:
Введите строку: карл у клары украл кораллы клара у карла украла кларнет
Введите искомую букву: а
Нашли слово: клара
Новые вопросы