помогите пожалуйста, очень прошу
Напишите программу на языке Паскаль для решения задачи:
1. Запросить от пользователя трехзначное натуральное число.
2. Разбить число на цифры.
3. Найти сумму и произведение цифр числа.
4. Вывести на экран ответ "Больше", если сумма больше произведения,
ответ "Меньше" , если сумма меньше произведения
и "Равно", если сумма равна произведению.

Ответы на вопрос
var a,c1,c2,c3,p,s:integer;
begin
p:=1;
read(a);
c1:=a mod 10;
a:= a div 10;
c2:=a mod 10;
a:= a div 10;
c2:=a mod 10;
p:=c1*c2*c3;
s:=c1+c2+c3;
if s>p then writeln('больше') else if s<p then writeln('меньше') else writeln('равно')
end.
Ответ:
var x, sum, comp, k:integer;
begin
readln(x);
comp := 1;
while x > 0 do
begin
k := x mod 10;
sum := sum + k;
comp := comp * k;
x := x div 10;
end;
if sum > comp then writeln('Больше');
if sum < comp then writeln('Меньше');
if sum = comp then writeln('Равно');
end.
Объяснение:
Просто и красиво. Работает с числами почти любой длинны. Без лишних переменных.