Информатика, вопрос задал mmanike , 2 года назад

ПОМОГИТЕ ПОЖАЛУЙСТА, ОЧЕНЬ ПРОШУ.
1)Составте программу в Паскаль. приписать по 1 в начало и в конец записи числа n (было n=3456, стало n=134561).
2) найти все двузначные числа, которые числа которые делятся на m или содержат цифру m.
3) Составить программу, которая прибавляет ко всем элементам массива по единице ,если массив заполняется с клавиатуры.

Ответы на вопрос

Ответил антагонист
4
1)
var a:integer;
begin
writeln('введите число');
readln(a);
writeln('1',a,'1');
end.
2)
var a,b,c:integer;
begin
writeln('введите число');
readln(a);
for c:=10 to 99 do
begin
if (c mod a = 0)  or (a = c mod 10) or (a = c div 10) then
writeln(c);
end;
end.
3) 
var b,c:integer;
a:array [1..100] of integer;
beginwriteln('введите длину массива');
readln(b);
for c:=1 to b do
begin
writeln('введите элемент массива');
readln(a[c]);
a[c]:=a[c]+1;
writeln(a[c]);
end;
end.

mmanike: спасибо
антагонист: вы не могли бы поставить лучший ответ? :D
mmanike: Я не могу, у меня нет значка! может потом появится, то я обязательно поставлю
mmanike: Я не могу, у меня нет значка! может потом появится, то я обязательно поставлю
антагонист: спасибо :D
Новые вопросы