Информатика, вопрос задал fetochka , 10 лет назад

Помогите, пожалуйста, очень, очень надо.

Написать программу с помощью цикла, которая позволяет ввести с клавиатуры последовательность из трех дробных чисел и после ввода каждого числа выводит среднее арифметическое полученной части последовательности. Ниже представлен рекомендуемый вид экрана во время работы программы:

*Обработка последовательности дробных чисел*

После ввода каждого числа нажмите <Enter>

- > 12.3

Введено чисел: 1 Среднее арифметическое: 12.30

- > 15

Введено чисел: 2 Среднее арифметическое: 13.65

- > 10

Введено чисел: 3 Среднее арифметическое: 12.43

Ответы на вопрос

Ответил Fergus
0

var a: array[1..3] of real;

x: real;
i: shortint;
begin
writeln('После ввода каждого числа нажмите <Enter>');
a[1]:=0; a[2]:=0; a[3]:=0;
for i:=1 to 3 do begin
write('->');
readln(a[i]);
x := ((a[1]+a[2]+a[3])/i)*100;
x := round(x);
x := x/100;
writeln('Введено чисел: ',i,' Среднее арифметическое: ',x);
end;
end.

Новые вопросы