Информатика, вопрос задал nekorkinam82 , 7 лет назад

Помогите пожалуйста. Нужно в паскале. Напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы программы на экран выводится сумма и произведение введенных чисел (не считая 0).

Ответы на вопрос

Ответил MrMiner1
0

Program n_1;

var a, b, n: double;

begin

   read (n);

   a:=n; b:=n;

   if n<>0 then read (n);

   while (n<>0) do begin

       a:=a+n;

       b:=b*n;

       read(n);

   end;

   writeln('Сумма чисел равна ', a:0:10, ' а их произведение ', b:0:10);

end.

Новые вопросы