Информатика, вопрос задал russtamtugusev111 , 6 лет назад

Помогите пожалуйста нужно написать программу на Паскале которая построит матрицу 10 на 10 случайными троичными числами и найдёт номер строки на которой сумма элементов будет минимальна


Леганда555: троичными или всё же трёхзначными?
russtamtugusev111: трёхзначными конечно же) если можешь помоги

Ответы на вопрос

Ответил Леганда555
2

var

 a: array[1..10, 1..10] of Integer;

 i, j, cursum, minsum, ind_minsum: Integer;

 

begin

 Randomize;

 for i := 1 to 10 do

   for j := 1 to 10 do

     a[i, j] := Random(900) + 100;

   

 cursum := 0;

 for i := 1 to 10 do

   cursum := cursum + a[1, i];

 

 minsum := cursum;

 ind_minsum := 1;

 

 for i := 2 to 10 do begin

   cursum := 0;

   for j := 1 to 10 do

     cursum := cursum + a[1, i];

   if cursum < minsum then begin

     minsum := cursum;

     ind_minsum := i;

   end;

 end;

   

 for i := 1 to 10 do begin

   for j := 1 to 10 do

     Write(a[i, j], ' ');

   WriteLn;

 end;

 

 WriteLn('минимальная сумма элементов в строке номер ', ind_minsum);

end.


Леганда555: Сама сумма сохранилась в minsum
russtamtugusev111: Огромное вам спасибо работает))
Артур998: Помогите по информатике пожалуйста 100 б. https://znanija.com/task/48826893
russtamtugusev111: здравствуйте, а как сделать так, чтобы например первая строка s1 нужно посчитать всю сумму всех чисел. И чтобы потом только уже программа написала в какой строке будет число минимальным?
Новые вопросы