Информатика, вопрос задал Rit989 , 10 лет назад

Помогите , пожалуйста . Нужно написать программу для Паскаль.

Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.

program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then 
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
 begin
max:=max;
else begin 
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.

Ответы на вопрос

Ответил nikolac
0
program ru;
var a,b,c,d,e,max:integer;
begin
writeln('Введите пять целых чисел');
readln(a,b,c,d,e);
max:=a;
if b>max then
max:=b;
if c>max then
max:=c;
if d>max then
max:=d;
if e>max then
max:=e;
writeln('Наибольшее число равно ', max);
end.
Ответил nikolac
0
Сейчас исправлю
Новые вопросы