Помогите пожалуйста нужно написать на c++
Создать массив вещественных чисел и заполнить его с клавиатуры.
Написать программу, которая выводит только целые части всех значений массива
с округлением.
2. Создать целочисленный массив на 10 элементов и заполнить его случайными
значениями.
Написать программу, которая находит минимальное нечетное значение массива и
выводит его на экран.
Ответы на вопрос
Код первой задачи:
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
// Создаем массив вещественных чисел размером 10 элементов
double numbers[10];
// Заполняем массив с клавиатуры
for (int i = 0; i < 10; i++)
{
cout << "Enter a number: ";
cin >> numbers[i];
}
// Выводим только целые части всех значений массива с округлением
for (int i = 0; i < 10; i++)
{
cout << "Integer part of " << numbers[i] << ": " << round(numbers[i]) << endl;
}
return 0;
}
Код второй задачи:
#include <iostream>
#include <cstdlib>
#include <ctime>
using namespace std;
int main()
{
// Создаем целочисленный массив размером 10 элементов
int numbers[10];
// Инициализируем генератор случайных чисел
srand(time(0));
// Заполняем массив случайными числами в диапазоне от 1 до 100
for (int i = 0; i < 10; i++)
{
numbers[i] = rand() % 100 + 1;
}
// Находим минимальное нечетное значение в массиве
int minOdd = 100; // Устанавливаем начальное значение минимума равным 100 (больше любого возможного значения в массиве)
for (int i = 0; i < 10; i++)
{
if (numbers[i] % 2 == 1 && numbers[i] < minOdd)
{
minOdd = numbers[i];
}
}
// Выводим минимальное нечетное значение на экран
cout << "Minimum odd number: " << minOdd << endl;
return 0;
}