помогите пожалуйста. напишите программу
Переместить максимальный элемент матрицы F(k,p) в правый верхний угол а минимальный элемент- в левый нижний
Ответы на вопрос
Ответил Аноним
0
const
k = 7;
p = 10;
var
i, j, e, max, min: integer;
F: array[1..k, 1..p] of integer;
begin
Randomize;
writeln('Исходная матрица');
max := -32768;
min := 32767;
for i := 1 to k do
begin
for j := 1 to p do
begin
e := random(100) - 50;
if e > max then max := e
else if e < min then min := e;
write(e:4);
F[i, j] := e
end;
writeln
end;
F[1, p] := max;
F[k, 1] := min;
writeln('Результирующая матрица');
for i := 1 to k do
begin
for j := 1 to p do
write(F[i, j]:4);
writeln
end
end.
Тестовое решение:
Исходная матрица
34 36 41 9 -4 39 29 1 15 -33
13 -9 -29 28 -45 -1 8 38 37 12
-33 45 3 35 -47 -14 -30 49 -29 -6
-50 -49 42 15 46 4 24 -21 -10 23
-14 30 -14 -46 33 -26 24 2 -3 -31
-27 15 47 25 -43 39 -17 -44 6 -40
19 30 -20 -29 -34 12 -2 5 32 0
Результирующая матрица
34 36 41 9 -4 39 29 1 15 49
13 -9 -29 28 -45 -1 8 38 37 12
-33 45 3 35 -47 -14 -30 49 -29 -6
-50 -49 42 15 46 4 24 -21 -10 23
-14 30 -14 -46 33 -26 24 2 -3 -31
-27 15 47 25 -43 39 -17 -44 6 -40
-50 30 -20 -29 -34 12 -2 5 32 0
k = 7;
p = 10;
var
i, j, e, max, min: integer;
F: array[1..k, 1..p] of integer;
begin
Randomize;
writeln('Исходная матрица');
max := -32768;
min := 32767;
for i := 1 to k do
begin
for j := 1 to p do
begin
e := random(100) - 50;
if e > max then max := e
else if e < min then min := e;
write(e:4);
F[i, j] := e
end;
writeln
end;
F[1, p] := max;
F[k, 1] := min;
writeln('Результирующая матрица');
for i := 1 to k do
begin
for j := 1 to p do
write(F[i, j]:4);
writeln
end
end.
Тестовое решение:
Исходная матрица
34 36 41 9 -4 39 29 1 15 -33
13 -9 -29 28 -45 -1 8 38 37 12
-33 45 3 35 -47 -14 -30 49 -29 -6
-50 -49 42 15 46 4 24 -21 -10 23
-14 30 -14 -46 33 -26 24 2 -3 -31
-27 15 47 25 -43 39 -17 -44 6 -40
19 30 -20 -29 -34 12 -2 5 32 0
Результирующая матрица
34 36 41 9 -4 39 29 1 15 49
13 -9 -29 28 -45 -1 8 38 37 12
-33 45 3 35 -47 -14 -30 49 -29 -6
-50 -49 42 15 46 4 24 -21 -10 23
-14 30 -14 -46 33 -26 24 2 -3 -31
-27 15 47 25 -43 39 -17 -44 6 -40
-50 30 -20 -29 -34 12 -2 5 32 0
Новые вопросы
Другие предметы,
2 года назад
Математика,
2 года назад
Физика,
9 лет назад
Алгебра,
9 лет назад
Биология,
10 лет назад