Помогите пожалуйста! Напишите эту программу ,но только с while.
Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 6. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число минимальное число, оканчивающееся на 6.
Ответы на вопрос
Ответил srzontmp
0
var n,k,m,mn: integer;
begin
write('n = '); readln(n);
mn:=30000;
k:=0;
while k<n do
begin
read(m);
if (abs(m mod 10) = 6) and (m<mn) then mn:=m;
k:=k+1;
end;
writeln(mn);
end.
n = 5
21 -26 18 -16 35
-26
begin
write('n = '); readln(n);
mn:=30000;
k:=0;
while k<n do
begin
read(m);
if (abs(m mod 10) = 6) and (m<mn) then mn:=m;
k:=k+1;
end;
writeln(mn);
end.
n = 5
21 -26 18 -16 35
-26
Ответил Katrin155664
0
можете ещё с одной прграммой помочь?
Ответил Katrin155664
0
очень надо!
Ответил srzontmp
0
Вопрос задайте.
Ответил Katrin155664
0
Помогите пожалуйста написать эту программу с while!
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — количество чисел, кратных 3.
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — количество чисел, кратных 3.
Ответил Katrin155664
0
я уже задала этот вопрос на сайте
Новые вопросы