Помогите пожалуйста написать программы в паскале АВС.
1) Написать программу вычисления средней линии трапеции.
2) Ввести 2 числа.Найти меньшее и вывести на экран.
3) Вывести на экран 15 член арифметической прогрессии ,если заданы а1 и разность d.
4) Записать программу нахождения периметра 8- миугольника,если каждая сторона,начиная со второй больше первой на 2 см.
(Помогите прошу вас,пожалуйста)
Ответы на вопрос
Ответил therealcf2014
0
1)
var a, b, l: real;
begin
write('Введите a, b>> ');
read(a, b);
l:=(a+b)/2;
writeln(l);
end.
2)
var a, b: integer;
begin
write('Введите 2 числа>> ');
read(a, b);
if a<b then writeln(a) else writeln(b);
end.
3)
var a1, d, n, sr: real;
begin
write('Введите a1, d>> ');
read(a1, d);
n:=15;
sr:=a1+d*(n-1);
writeln(sr);
end.
4)
var
a, d, p: real;
i: byte;
begin
write('Введите первую сторону>> ');
read(a);
for i:=1 to 8 do
begin
p:=p+a;
a:=a+2;
end;
writeln('P = ', p);
end.
var a, b, l: real;
begin
write('Введите a, b>> ');
read(a, b);
l:=(a+b)/2;
writeln(l);
end.
2)
var a, b: integer;
begin
write('Введите 2 числа>> ');
read(a, b);
if a<b then writeln(a) else writeln(b);
end.
3)
var a1, d, n, sr: real;
begin
write('Введите a1, d>> ');
read(a1, d);
n:=15;
sr:=a1+d*(n-1);
writeln(sr);
end.
4)
var
a, d, p: real;
i: byte;
begin
write('Введите первую сторону>> ');
read(a);
for i:=1 to 8 do
begin
p:=p+a;
a:=a+2;
end;
writeln('P = ', p);
end.
Новые вопросы